package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0x(([[:xdigit:]]{7}\b)|([[:xdigit:]]{6}\b)|([[:xdigit:]]{5}\b)|([[:xdigit:]]{4}\b)|([[:xdigit:]]{3}\b)|([[:xdigit:]]{2}\b)|([[:xdigit:]]{1}\b))`)
var str = `{0x1023350, 0x3014},
{0x1023954, 0x3007},
{0x1023960, 0x10F},
{0x102396C, 0x2FF},
{0x10219, 0x16},`
var substitution = "0x(?{2}0)(?{3}00)(?{4}000)(?{5}0000)(?{6}00000)(?{7}000000)(?{8}0000000)${1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}