const regex = /0x(([[:xdigit:]]{7}\b)|([[:xdigit:]]{6}\b)|([[:xdigit:]]{5}\b)|([[:xdigit:]]{4}\b)|([[:xdigit:]]{3}\b)|([[:xdigit:]]{2}\b)|([[:xdigit:]]{1}\b))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0x(([[:xdigit:]]{7}\\b)|([[:xdigit:]]{6}\\b)|([[:xdigit:]]{5}\\b)|([[:xdigit:]]{4}\\b)|([[:xdigit:]]{3}\\b)|([[:xdigit:]]{2}\\b)|([[:xdigit:]]{1}\\b))', 'gm')
const str = `{0x1023350, 0x3014},
{0x1023954, 0x3007},
{0x1023960, 0x10F},
{0x102396C, 0x2FF},
{0x10219, 0x16},`;
const subst = `0x(?{2}0)(?{3}00)(?{4}000)(?{5}0000)(?{6}00000)(?{7}000000)(?{8}0000000)${1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);