import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0x(([[:xdigit:]]{7}\\b)|([[:xdigit:]]{6}\\b)|([[:xdigit:]]{5}\\b)|([[:xdigit:]]{4}\\b)|([[:xdigit:]]{3}\\b)|([[:xdigit:]]{2}\\b)|([[:xdigit:]]{1}\\b))";
final String string = "{0x1023350, 0x3014},\n"
+ "{0x1023954, 0x3007},\n"
+ "{0x1023960, 0x10F},\n"
+ "{0x102396C, 0x2FF},\n"
+ "{0x10219, 0x16},";
final String subst = "0x(?{2}0)(?{3}00)(?{4}000)(?{5}0000)(?{6}00000)(?{7}000000)(?{8}0000000)${1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}