#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?uxms)^" & @CRLF & _
" # Static keyword" & @CRLF & _
" # Declares a static method ONLY if type is also present" & @CRLF & _
" (?:" & @CRLF & _
" (static)" & @CRLF & _
" \s+" & @CRLF & _
" )?" & @CRLF & _
" # Return type" & @CRLF & _
" (?:" & @CRLF & _
" (" & @CRLF & _
" (?:[\w\|_\\\\]*\$this[\w\|_\\\\]*)" & @CRLF & _
" |" & @CRLF & _
" (?:" & @CRLF & _
" (?:[\w\|_\\\\]+)" & @CRLF & _
" # array notation" & @CRLF & _
" (?:\[\])*" & @CRLF & _
" )*+" & @CRLF & _
" )" & @CRLF & _
" \s+" & @CRLF & _
" )?" & @CRLF & _
" # Method name" & @CRLF & _
" ([\w_]+)" & @CRLF & _
" # Arguments" & @CRLF & _
" (?:" & @CRLF & _
" \((.*(?=\)))\)" & @CRLF & _
" )?" & @CRLF & _
" \s*" & @CRLF & _
" # Description" & @CRLF & _
" (.*)" & @CRLF & _
" $"
Local $sString = "static array[] ISO8859_1(array $d = [], string $s="", $f=array()) foo bar baz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")