import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ " # Static keyword\n"
+ " # Declares a static method ONLY if type is also present\n"
+ " (?:\n"
+ " (static)\n"
+ " \\s+\n"
+ " )?\n"
+ " # Return type\n"
+ " (?:\n"
+ " (\n"
+ " (?:[\\w\\|_\\\\\\\\]*\\$this[\\w\\|_\\\\\\\\]*)\n"
+ " |\n"
+ " (?:\n"
+ " (?:[\\w\\|_\\\\\\\\]+)\n"
+ " # array notation\n"
+ " (?:\\[\\])*\n"
+ " )*+\n"
+ " )\n"
+ " \\s+\n"
+ " )?\n"
+ " # Method name\n"
+ " ([\\w_]+)\n"
+ " # Arguments\n"
+ " (?:\n"
+ " \\((.*(?=\\)))\\)\n"
+ " )?\n"
+ " \\s*\n"
+ " # Description\n"
+ " (.*)\n"
+ " $";
final String string = "static array[] ISO8859_1(array $d = [], string $s=\"\", $f=array()) foo bar baz";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.COMMENTS | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}