re = /^
# Static keyword
# Declares a static method ONLY if type is also present
(?:
(static)
\s+
)?
# Return type
(?:
(
(?:[\w\|_\\\\]*\$this[\w\|_\\\\]*)
|
(?:
(?:[\w\|_\\\\]+)
# array notation
(?:\[\])*
)*+
)
\s+
)?
# Method name
([\w_]+)
# Arguments
(?:
\((.*(?=\)))\)
)?
\s*
# Description
(.*)
$/xm
str = 'static array[] ISO8859_1(array $d = [], string $s="", $f=array()) foo bar baz'
# Print the match result
str.match(re) do |match|
puts match.to_s
end