$re = '/^
# Static keyword
# Declares a static method ONLY if type is also present
(?:
(static)
\s+
)?
# Return type
(?:
(
(?:[\w\|_\\\\\\\\]*\$this[\w\|_\\\\\\\\]*)
|
(?:
(?:[\w\|_\\\\\\\\]+)
# array notation
(?:\[\])*
)*+
)
\s+
)?
# Method name
([\w_]+)
# Arguments
(?:
\((.*(?=\)))\)
)?
\s*
# Description
(.*)
$/uxms';
$str = 'static array[] ISO8859_1(array $d = [], string $s="", $f=array()) foo bar baz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);