const regex = /^
# Static keyword
# Declares a static method ONLY if type is also present
(?:
(static)
\s+
)?
# Return type
(?:
(
(?:[\w\|_\\\\]*\$this[\w\|_\\\\]*)
|
(?:
(?:[\w\|_\\\\]+)
# array notation
(?:\[\])*
)*+
)
\s+
)?
# Method name
([\w_]+)
# Arguments
(?:
\((.*(?=\)))\)
)?
\s*
# Description
(.*)
$/ums;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
# Static keyword
# Declares a static method ONLY if type is also present
(?:
(static)
\\s+
)?
# Return type
(?:
(
(?:[\\w\\|_\\\\\\\\]*\\$this[\\w\\|_\\\\\\\\]*)
|
(?:
(?:[\\w\\|_\\\\\\\\]+)
# array notation
(?:\\[\\])*
)*+
)
\\s+
)?
# Method name
([\\w_]+)
# Arguments
(?:
\\((.*(?=\\)))\\)
)?
\\s*
# Description
(.*)
$', 'ums')
const str = `static array[] ISO8859_1(array \$d = [], string \$s="", \$f=array()) foo bar baz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}