import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(M\\.D\\.,? ?$)|(PhD,? ?$)|(MPH,? ?)|(,)";
final String string = "name\n"
+ "John McNamara\n"
+ "Jane Adams, M.D.\n"
+ "Nour Abd Almohsen Jr M.D.\n"
+ "Alex Ambrose PhD\n"
+ "Nancy Ann Brown, MPH, PhD\n"
+ "Kathy W.\n"
+ "Jack Joshua Smith White\n"
+ "MPHJackie Goldman\n"
+ "Mort Evans";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}