import re
regex = re.compile(r"(M\.D\.,? ?$)|(PhD,? ?$)|(MPH,? ?)|(,)", flags=re.MULTILINE)
test_str = ("name\n"
"John McNamara\n"
"Jane Adams, M.D.\n"
"Nour Abd Almohsen Jr M.D.\n"
"Alex Ambrose PhD\n"
"Nancy Ann Brown, MPH, PhD\n"
"Kathy W.\n"
"Jack Joshua Smith White\n"
"MPHJackie Goldman\n"
"Mort Evans")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)