$re = '/(M\.D\.,? ?$)|(PhD,? ?$)|(MPH,? ?)|(,)/m';
$str = 'name
John McNamara
Jane Adams, M.D.
Nour Abd Almohsen Jr M.D.
Alex Ambrose PhD
Nancy Ann Brown, MPH, PhD
Kathy W.
Jack Joshua Smith White
MPHJackie Goldman
Mort Evans';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;