// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(M\.D\.,? ?$)|(PhD,? ?$)|(MPH,? ?)|(,)").unwrap();
let string = "name
John McNamara
Jane Adams, M.D.
Nour Abd Almohsen Jr M.D.
Alex Ambrose PhD
Nancy Ann Brown, MPH, PhD
Kathy W.
Jack Joshua Smith White
MPHJackie Goldman
Mort Evans";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}