const regex = /(M\.D\.,? ?$)|(PhD,? ?$)|(MPH,? ?)|(,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(M\\.D\\.,? ?$)|(PhD,? ?$)|(MPH,? ?)|(,)', 'gm')
const str = `name
John McNamara
Jane Adams, M.D.
Nour Abd Almohsen Jr M.D.
Alex Ambrose PhD
Nancy Ann Brown, MPH, PhD
Kathy W.
Jack Joshua Smith White
MPHJackie Goldman
Mort Evans`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);