#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<name>([\w\-]+)+\.?)(?P<version>(\.?\d+\.?)+\.?)(\.[a-z]{3,})"
Local $sString = "app-name.1.2.3.exe" & @CRLF & _
"appname.v1.2.3.exe " & @CRLF & _
"appname.v1.02.03.exe " & @CRLF & _
"appname71name.1.2.3.exe " & @CRLF & _
"appname71.1.2.3.exe" & @CRLF & _
"appname-1.2.3.exe " & @CRLF & _
"appname-v1.2.3.exe " & @CRLF & _
"app-name-v1.2.3.exe " & @CRLF & _
"appname-v1.02.03.exe " & @CRLF & _
"appname71name-1.2.3.exe" & @CRLF & _
"appname71-1.2.3.exe " & @CRLF & _
"appname_1.2.3.exe " & @CRLF & _
"appname_v1.2.3.exe " & @CRLF & _
"appname_v1.02.03.exe " & @CRLF & _
"appname71name_1.2.3.exe " & @CRLF & _
"appname71_1.2.3.exe "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")