re = /(?P<name>([\w\-]+)+\.?)(?P<version>(\.?\d+\.?)+\.?)(\.[a-z]{3,})/m
str = 'app-name.1.2.3.exe
appname.v1.2.3.exe
appname.v1.02.03.exe
appname71name.1.2.3.exe
appname71.1.2.3.exe
appname-1.2.3.exe
appname-v1.2.3.exe
app-name-v1.2.3.exe
appname-v1.02.03.exe
appname71name-1.2.3.exe
appname71-1.2.3.exe
appname_1.2.3.exe
appname_v1.2.3.exe
appname_v1.02.03.exe
appname71name_1.2.3.exe
appname71_1.2.3.exe '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end