using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<name>([\w\-]+)+\.?)(?P<version>(\.?\d+\.?)+\.?)(\.[a-z]{3,})";
string input = @"app-name.1.2.3.exe
appname.v1.2.3.exe
appname.v1.02.03.exe
appname71name.1.2.3.exe
appname71.1.2.3.exe
appname-1.2.3.exe
appname-v1.2.3.exe
app-name-v1.2.3.exe
appname-v1.02.03.exe
appname71name-1.2.3.exe
appname71-1.2.3.exe
appname_1.2.3.exe
appname_v1.2.3.exe
appname_v1.02.03.exe
appname71name_1.2.3.exe
appname71_1.2.3.exe ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}