package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<name>([\w\-]+)+\.?)(?P<version>(\.?\d+\.?)+\.?)(\.[a-z]{3,})`)
var str = `app-name.1.2.3.exe
appname.v1.2.3.exe
appname.v1.02.03.exe
appname71name.1.2.3.exe
appname71.1.2.3.exe
appname-1.2.3.exe
appname-v1.2.3.exe
app-name-v1.2.3.exe
appname-v1.02.03.exe
appname71name-1.2.3.exe
appname71-1.2.3.exe
appname_1.2.3.exe
appname_v1.2.3.exe
appname_v1.02.03.exe
appname71name_1.2.3.exe
appname71_1.2.3.exe `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}