import Foundation
let pattern = #"(?P<name>([\w\-]+)+\.?)(?P<version>(\.?\d+\.?)+\.?)(\.[a-z]{3,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
app-name.1.2.3.exe
appname.v1.2.3.exe
appname.v1.02.03.exe
appname71name.1.2.3.exe
appname71.1.2.3.exe
appname-1.2.3.exe
appname-v1.2.3.exe
app-name-v1.2.3.exe
appname-v1.02.03.exe
appname71name-1.2.3.exe
appname71-1.2.3.exe
appname_1.2.3.exe
appname_v1.2.3.exe
appname_v1.02.03.exe
appname71name_1.2.3.exe
appname71_1.2.3.exe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)