package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\/[^\n\r]+?(?:\*\)|[\n\r])`)
var str = `// This is a comment
//This is a comment*)
// something *) something *)
This is not a comment
This is not a comment *)
This is not a comment // with a double forward slash inline`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}