const regex = /\/\/[^\n\r]+?(?:\*\)|[\n\r])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/[^\\n\\r]+?(?:\\*\\)|[\\n\\r])', 'g')
const str = `// This is a comment
//This is a comment*)
// something *) something *)
This is not a comment
This is not a comment *)
This is not a comment // with a double forward slash inline`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}