re = /\/\/[^\n\r]+?(?:\*\)|[\n\r])/
str = '// This is a comment
//This is a comment*)
// something *) something *)
This is not a comment
This is not a comment *)
This is not a comment // with a double forward slash inline'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end