$re = '/\/\/[^\n\r]+?(?:\*\)|[\n\r])/';
$str = '// This is a comment
//This is a comment*)
// something *) something *)
This is not a comment
This is not a comment *)
This is not a comment // with a double forward slash inline';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);