import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/[^\\n\\r]+?(?:\\*\\)|[\\n\\r])";
final String string = "// This is a comment\n\n"
+ "//This is a comment*)\n\n"
+ "// something *) something *)\n\n"
+ "This is not a comment \n\n"
+ "This is not a comment *)\n\n"
+ "This is not a comment // with a double forward slash inline";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}