use strict;
my $str = '<p>sanktsya boshlandi.</p>
<p><img src="https://img.com/Sqstso.jpeg" /></p>';
my $regex = qr/<[^>]*>(*SKIP)(*FAIL)|[qwrtpsdfghklzxcvbnm]+\Kts/ip;
my $subst = 's';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";