re = /<[^>]*>(*SKIP)(*FAIL)|[qwrtpsdfghklzxcvbnm]+\Kts/i
str = '<p>sanktsya boshlandi.</p>
<p><img src="https://img.com/Sqstso.jpeg" /></p>'
subst = 's'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result