package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)matei 160 arrays`)
var str = `<?php
$favoriteAnimes = ["Hunter x Hunter", "Gurren Lagann", "One Piece", "JoJo", "Yu Yu Hakusho", "Mob Psycho 100"];
if (!empty($favoriteAnimes)) {
foreach ($favoriteAnimes as $anime) {
echo $anime . "<br>";
}
}
?>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}