const regex = /matei 160 arrays/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('matei 160 arrays', 'gm')
const str = `<?php
\$favoriteAnimes = ["Hunter x Hunter", "Gurren Lagann", "One Piece", "JoJo", "Yu Yu Hakusho", "Mob Psycho 100"];
if (!empty(\$favoriteAnimes)) {
foreach (\$favoriteAnimes as \$anime) {
echo \$anime . "<br>";
}
}
?>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}