import re
regex = re.compile(r"matei 160 arrays", flags=re.MULTILINE)
test_str = ("<?php\n"
"$favoriteAnimes = [\"Hunter x Hunter\", \"Gurren Lagann\", \"One Piece\", \"JoJo\", \"Yu Yu Hakusho\", \"Mob Psycho 100\"]; \n\n"
"if (!empty($favoriteAnimes)) {\n"
" foreach ($favoriteAnimes as $anime) {\n"
" echo $anime . \"<br>\";\n"
" }\n"
"}\n"
"?>\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")