import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "matei 160 arrays";
final String string = "<?php\n"
+ "$favoriteAnimes = [\"Hunter x Hunter\", \"Gurren Lagann\", \"One Piece\", \"JoJo\", \"Yu Yu Hakusho\", \"Mob Psycho 100\"]; \n\n"
+ "if (!empty($favoriteAnimes)) {\n"
+ " foreach ($favoriteAnimes as $anime) {\n"
+ " echo $anime . \"<br>\";\n"
+ " }\n"
+ "}\n"
+ "?>\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}