$re = '/matei 160 arrays/m';
$str = '<?php
$favoriteAnimes = ["Hunter x Hunter", "Gurren Lagann", "One Piece", "JoJo", "Yu Yu Hakusho", "Mob Psycho 100"];
if (!empty($favoriteAnimes)) {
foreach ($favoriteAnimes as $anime) {
echo $anime . "<br>";
}
}
?>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);