import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(¬zinit)(?<remaining_command>(?<simple_remaining>.+$(?<![\\\\'\"]))|(?<continuation_line>.+(?<continuation>(?<slash_continuation>[\\\\]\\n)|(?<quoted_continuation>[\"]\\n[\\s\\S]*(?<!(?:[\\\\]{2})*[^\\\\])[\"])))*.+)";
final String string = "¬zinit light-mode for \\\n"
+ " psprint/zsh-cmd-architect \\\n"
+ " psprint/zsh-editing-workbench\n\n"
+ "¬zinit light-mode for agkozak/zhooks\n\n"
+ "¬zinit atclone\"dircolors -b LS_COLORS > c.zsh\" \\\n"
+ " atpull'%atclone' \\\n"
+ " pick\"c.zsh\" \\\n"
+ " nocompile'!' \\\n"
+ " atload'zstyle \":completion:*\" list-colors \"${(s.:.)LS_COLORS}\"' \\\n"
+ " for disco0/LS_COLORS\n\n"
+ "¬zinit atclone\"\n"
+ " autoload -Uz \\${PWD}/functions/zcolors || {\n"
+ " builtin print -Pu2 -- \\\n"
+ " '%F{1} \\\"WARNING: Failed to autoload zcolors command for initialization.%f\\\";\n"
+ " return 1\n"
+ " };\n"
+ " zcolors $LS_COLORS >! ~/.zsh/zcolors.zsh\n"
+ " \" \\\n"
+ " atpull'%atclone' \\\n"
+ " pick\"c.zsh\" \\\n"
+ " nocompile'!' \\\n"
+ " atload'zstyle \":completion:*\" list-colors \"${(s.:.)LS_COLORS}\"' \\\n"
+ " for marlonrichert/zcolors\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}