import Foundation
let pattern = #"(¬zinit)(?<remaining_command>(?<simple_remaining>.+$(?<![\\'"]))|(?<continuation_line>.+(?<continuation>(?<slash_continuation>[\\]\n)|(?<quoted_continuation>["]\n[\s\S]*(?<!(?:[\\]{2})*[^\\])["])))*.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
¬zinit light-mode for \
psprint/zsh-cmd-architect \
psprint/zsh-editing-workbench
¬zinit light-mode for agkozak/zhooks
¬zinit atclone"dircolors -b LS_COLORS > c.zsh" \
atpull'%atclone' \
pick"c.zsh" \
nocompile'!' \
atload'zstyle ":completion:*" list-colors "${(s.:.)LS_COLORS}"' \
for disco0/LS_COLORS
¬zinit atclone"
autoload -Uz \${PWD}/functions/zcolors || {
builtin print -Pu2 -- \
'%F{1} \"WARNING: Failed to autoload zcolors command for initialization.%f\";
return 1
};
zcolors $LS_COLORS >! ~/.zsh/zcolors.zsh
" \
atpull'%atclone' \
pick"c.zsh" \
nocompile'!' \
atload'zstyle ":completion:*" list-colors "${(s.:.)LS_COLORS}"' \
for marlonrichert/zcolors
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)