#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)mysite.com\/newsletter(?:-it)?\/(?:thank|grazie|obrigado|merci|gracias|dank).*"
Local $sString = "mysite.com/newsletter/thank-you" & @CRLF & _
"mysite.com/blog/thanksgiving-recipes" & @CRLF & _
"mysite.com/case-studies/thanks" & @CRLF & _
"mysite.com/newsletter-it/grazie-per-subscribe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")