re = /mysite.com\/newsletter(?:-it)?\/(?:thank|grazie|obrigado|merci|gracias|dank).*/m
str = 'mysite.com/newsletter/thank-you
mysite.com/blog/thanksgiving-recipes
mysite.com/case-studies/thanks
mysite.com/newsletter-it/grazie-per-subscribe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end