using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mysite.com\/newsletter(?:-it)?\/(?:thank|grazie|obrigado|merci|gracias|dank).*";
string input = @"mysite.com/newsletter/thank-you
mysite.com/blog/thanksgiving-recipes
mysite.com/case-studies/thanks
mysite.com/newsletter-it/grazie-per-subscribe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}