// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)mysite.com\/newsletter(?:-it)?\/(?:thank|grazie|obrigado|merci|gracias|dank).*").unwrap();
let string = "mysite.com/newsletter/thank-you
mysite.com/blog/thanksgiving-recipes
mysite.com/case-studies/thanks
mysite.com/newsletter-it/grazie-per-subscribe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}