import Foundation
let pattern = #"mysite.com\/newsletter(?:-it)?\/(?:thank|grazie|obrigado|merci|gracias|dank).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
mysite.com/newsletter/thank-you
mysite.com/blog/thanksgiving-recipes
mysite.com/case-studies/thanks
mysite.com/newsletter-it/grazie-per-subscribe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)