#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\/(sub[1-3]\.)?mydomain\.com\/d\/([^\/]+)(?|\/)"
Local $sString = "http://sub1.mydomain.com/d/3542re6s/somthing.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")