// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/\/(sub[1-3]\.)?mydomain\.com\/d\/([^\/]+)(?|\/)").unwrap();
let string = "http://sub1.mydomain.com/d/3542re6s/somthing.html";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}