package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\/(sub[1-3]\.)?mydomain\.com\/d\/([^\/]+)(?|\/)`)
var str = `http://sub1.mydomain.com/d/3542re6s/somthing.html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}