$re = '/\/\/(sub[1-3]\.)?mydomain\.com\/d\/([^\/]+)(?|\/)/';
$str = 'http://sub1.mydomain.com/d/3542re6s/somthing.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);