import Foundation
let pattern = #"\/\/(sub[1-3]\.)?mydomain\.com\/d\/([^\/]+)(?|\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://sub1.mydomain.com/d/3542re6s/somthing.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}