#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z0-9]{6}"
Local $sString = "Stephen Avenue 700 Center St SE Calgary, AB T2G5P6" & @CRLF & _
"" & @CRLF & _
"Montgomery 4611 Bowness Rd NW Calgary, AB T3B0S4" & @CRLF & _
"" & @CRLF & _
"Uptown 17th Ave 1022 17 Ave SW Calgary, AB T2T0A5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")