// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z0-9]{6}").unwrap();
let string = "Stephen Avenue 700 Center St SE Calgary, AB T2G5P6
Montgomery 4611 Bowness Rd NW Calgary, AB T3B0S4
Uptown 17th Ave 1022 17 Ave SW Calgary, AB T2T0A5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}