const regex = /[A-Z0-9]{6}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z0-9]{6}', 'g')
const str = `Stephen Avenue 700 Center St SE Calgary, AB T2G5P6
Montgomery 4611 Bowness Rd NW Calgary, AB T3B0S4
Uptown 17th Ave 1022 17 Ave SW Calgary, AB T2T0A5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}