using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z0-9]{6}";
string input = @"Stephen Avenue 700 Center St SE Calgary, AB T2G5P6
Montgomery 4611 Bowness Rd NW Calgary, AB T3B0S4
Uptown 17th Ave 1022 17 Ave SW Calgary, AB T2T0A5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}