re = /[A-Z0-9]{6}/
str = 'Stephen Avenue 700 Center St SE Calgary, AB T2G5P6
Montgomery 4611 Bowness Rd NW Calgary, AB T3B0S4
Uptown 17th Ave 1022 17 Ave SW Calgary, AB T2T0A5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end