# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|\G)( {4}|\t)/\t/mg;t' <<< "<?php
class SomeClass
{
var $property = 1;
function double(int $x)
{
$result = $x + $x;
// line already indented with tabs
// line started with tab, but followed with spaces
// line has 4 spaces in the middle
// line endings with 4 spaces
return $result;
}
}"