import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\G)( {4}|\\t)";
final String string = "<?php\n\n"
+ "class SomeClass\n"
+ "{\n"
+ " var $property = 1;\n\n"
+ " function double(int $x)\n"
+ " {\n"
+ " $result = $x + $x;\n"
+ " // line already indented with tabs\n"
+ " // line started with tab, but followed with spaces\n"
+ " // line has 4 spaces in the middle\n"
+ " // line endings with 4 spaces \n"
+ " return $result;\n"
+ " }\n"
+ "}";
final String subst = "\\t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}