const regex = /(?:^|\G)( {4}|\t)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\G)( {4}|\\t)', 'mg')
const str = `<?php
class SomeClass
{
var \$property = 1;
function double(int \$x)
{
\$result = \$x + \$x;
// line already indented with tabs
// line started with tab, but followed with spaces
// line has 4 spaces in the middle
// line endings with 4 spaces
return \$result;
}
}`;
const subst = `\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);